CUP Eclipse Plugin

The CUP Eclipse Plugin serves as an IDE for developing CUP based parsers. It is intended to help in grammar engineering and action code debugging. It was produced during a lab course by a group of students (B. Engeser, S. Pretscher, J. Roith in alphabetical order).


Download / Installation

The CUP Eclipse Plugin is designed for Java 1.8 and Eclipse 4.4 (Luna). Open Eclipse and navigate to Help/Install New Software... Then add the URL in the following dialog to the Available Software Sites:


Grammar development view:

In the grammar development view, there is a hierarchical outline as well as syntax highlighting and error markers:

Conclict resolution view:

In the conflict resoultion view, the programmer can inspect all shift/reduce or reduce/reduce errors, and is presented with a chain of symbols, which trigger the conflict in the canonical LALR(1) automaton. A hyperlink takes the programmer to the corresponding LR(1)-state-trace:

Automaton view:

In the automaton view, the programmer can inspect the generated automaton. Hovering on the states yields the items and corresponding lookahead sets: